# JsonForm giving errors while upgrade angular 14.3.0 to 15.2.10

**URL:** <https://jsonforms.discourse.group/t/jsonform-giving-errors-while-upgrade-angular-14-3-0-to-15-2-10/2230>\
**Category:** General\
**Created:** [July 12, 2024, 12:02pm UTC](https://jsonforms.discourse.group/t/jsonform-giving-errors-while-upgrade-angular-14-3-0-to-15-2-10/2230 "2024-07-12T12:02:00Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jainrahul2987](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@jainrahul2987](https://jsonforms.discourse.group/u/jainrahul2987)\
**Post date:** [July 12, 2024, 12:02pm UTC](https://jsonforms.discourse.group/t/jsonform-giving-errors-while-upgrade-angular-14-3-0-to-15-2-10/2230/1 "2024-07-12T12:02:00Z")

</div>

I am using below packages of angular:

```auto
    "@angular/animations": "^15.2.10",
    "@angular/cdk": "^15.2.9",
    "@angular/common": "^15.2.10",
    "@angular/compiler": "^15.2.10",
    "@angular/core": "^15.2.10",
    "@angular/flex-layout": "^15.0.0-beta.42",
    "@angular/forms": "^15.2.10",
    "@angular/localize": "^15.2.10",
    "@angular/material": "^15.2.9",
    "@angular/platform-browser": "^15.2.10",
    "@angular/platform-browser-dynamic": "^15.2.10",
    "@angular/router": "^15.2.10",

```

and for jsonform

```auto
    "@jsonforms/angular": "^3.3.0",
    "@jsonforms/angular-material": "^3.3.0",
    "@jsonforms/core": "^3.3.0",

```

But I am getting these errros while compiling the code with npm run start, I am attaching the screenshot of errors,

Any help please ??

 ![Screenshot 2024-07-12 at 12.58.56 p.m.](https://global.discourse-cdn.com/free1/uploads/jsonforms/original/2X/8/862d1f2a6cc6abb183e7e32d91e8f2e152e493b6.png)

---

<div class="post-metadata">

**Author:** ![lucas-koehler](https://yyz2.discourse-cdn.com/free1/user_avatar/jsonforms.discourse.group/lucas-koehler/32/336_2.png) [@lucas-koehler](https://jsonforms.discourse.group/u/lucas-koehler)\
**Post date:** [July 16, 2024, 7:54am UTC](https://jsonforms.discourse.group/t/jsonform-giving-errors-while-upgrade-angular-14-3-0-to-15-2-10/2230/2 "2024-07-16T07:54:09Z")

</div>

Hi @jainrahul2987 ,

Angular 15.x is only supported in version `3.2.0-alpha.4`.  
With Jsonforms `3.2.0` and `3.2.1`, you can use Angular 16 or 17. Starting with version `3.3.0`, you can use Angular 17 and 18.

Hope that helps,  
Lucas

---

<div class="post-metadata">

**Author:** ![jainrahul2987](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@jainrahul2987](https://jsonforms.discourse.group/u/jainrahul2987)\
**Post date:** [July 26, 2024, 8:28am UTC](https://jsonforms.discourse.group/t/jsonform-giving-errors-while-upgrade-angular-14-3-0-to-15-2-10/2230/3 "2024-07-26T08:28:21Z")

</div>

Thanks lucas for the help, I am able to fix this issue with the suggested version of jsonforms.
